using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\\\[\s*(?P<brace_bloc>.*?)\s*\\\]";
string input = @"foo
\[ \left\\{
\begin{array}{cl}3=&1 + 2\\4=&2 + 2\end{array}
\right.
\]
bar";
RegexOptions options = RegexOptions.Multiline | RegexOptions.Singleline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}