// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?ms)\\\[\s*(?P<brace_bloc>.*?)\s*\\\]").unwrap();
let string = "foo
\\[ \\left\\\\{
\\begin{array}{cl}3=&1 + 2\\\\4=&2 + 2\\end{array}
\\right.
\\]
bar";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}