import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?![\\x20\\x27\\x2D]|.*?[\\p{Lu}]{2}|.*?[\\x20]{2}|.*?[\\x27]{2}|.*?[\\x2D]{2}|.*?(\\x20\\x2D|\\x2D\\x20)|.*?(\\x27\\x2D|\\x2D\\x27)|.*?(\\x27[\\w]+\\x27(\\x20|$)))[\\p{L}\\x20\\x27\\x2D]+$(?<![\\x20\\x2D])";
final String string = "Jean-Claude Van Damme\n"
+ "Marcin Różalski\n"
+ "MICKEY MOUSE\n"
+ "Jesus Christ\n"
+ "Arnold 'Terminator' Schwarzenegger\n"
+ "Shaquille O'Neal";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}