const regex = /^(?![\x20\x27\x2D]|.*?[\p{Lu}]{2}|.*?[\x20]{2}|.*?[\x27]{2}|.*?[\x2D]{2}|.*?(\x20\x2D|\x2D\x20)|.*?(\x27\x2D|\x2D\x27)|.*?(\x27[\w]+\x27(\x20|$)))[\p{L}\x20\x27\x2D]+$(?<![\x20\x2D])/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?![\\x20\\x27\\x2D]|.*?[\\p{Lu}]{2}|.*?[\\x20]{2}|.*?[\\x27]{2}|.*?[\\x2D]{2}|.*?(\\x20\\x2D|\\x2D\\x20)|.*?(\\x27\\x2D|\\x2D\\x27)|.*?(\\x27[\\w]+\\x27(\\x20|$)))[\\p{L}\\x20\\x27\\x2D]+$(?<![\\x20\\x2D])', 'gm')
const str = `Jean-Claude Van Damme
Marcin Różalski
MICKEY MOUSE
Jesus Christ
Arnold 'Terminator' Schwarzenegger
Shaquille O'Neal`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}