# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?:<p>(?=[^<>]*<\/p>)|\G(?!^))[^\d<>]*\d+\K\h/ /gm;t' <<< "<p>My 90 days 123 work.</p>"