package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?'number'\d+(\.\d+)?)(?'quantifier'\W?[a-z,A-Z,А-Я,а-я])?`)
var str = `Необходимо принимать сумму
Варианты
20.0
20
5к
5 к
5 т
2 000
К и т должны быть отдельно`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}