// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(?'number'\d+(\.\d+)?)(?'quantifier'\W?[a-z,A-Z,А-Я,а-я])?").unwrap();
let string = "Необ ходимо принимать сумму
Варианты
20.0
20
5к
5 к
5 т
2 000
К и т должны быть отдельно";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}