#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?'number'\d{1,5}(\.\d{1,2})?)(?'quantifier'\W?[a-z,A-Z,А-Я,а-я])?"
Local $sString = "Необходимо принимать сумму" & @CRLF & _
"Варианты" & @CRLF & _
"20.0" & @CRLF & _
"20 f" & @CRLF & _
"5к" & @CRLF & _
"5 к" & @CRLF & _
"5 т" & @CRLF & _
"2 000 " & @CRLF & _
"К и т должны быть отдельно"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")