import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?'number'\\d{1,5}(\\.\\d{1,2})?)(?'quantifier'\\W?[a-z,A-Z,А-Я,а-я])?";
final String string = "Необходимо принимать сумму\n"
+ "Варианты\n"
+ "20.0\n"
+ "20 f\n"
+ "5к\n"
+ "5 к\n"
+ "5 т\n"
+ "2 000 \n"
+ "К и т должны быть отдельно";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}