re = /^(?=.*[A-Z]|())(?=.*[a-z]|())(?=[^0-9\r\n]+$|())(?=[^\\!-\/:-@\[\]-`{-~\r\n]+$|())(?=.{2,40}$|()).+/m
str = '9876LKIU
P,a
]
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end