# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\b(?:(?<FirstOctet>(?:25[0-5]|2[0-4][0-9]|[0-1][0-9]{2})|(?:[0-9]{1,2}))\.(?<SecondOctet>(?:25[0-5]|2[0-4][0-9]|[0-1][0-9]{2})|(?:[0-9]{1,2}))\.(?<ThirdOctet>(?:25[0-5]|2[0-4][0-9]|[0-1][0-9]{2})|(?:[0-9]{1,2}))\.(?<FourthOctet>(?:25[0-5]|2[0-4][0-9]|[0-1][0-9]{2})|(?:[0-9]{1,2}))){1}\b"
test_str = ("Should Match:\n"
"204.131.100.104\n"
"255.255.005.055\n"
"192.168.10.1\n"
"172.16.1.1\n"
"10.10.10.1\n"
"1.2.3.4\n"
"255.255.255.255\n"
"001.02.3.004\n"
"123.145.254.189:8080\n"
"1.2.3.4-4.3.20.1\n"
"4.3.2.1.9.8.7.6\n"
"Shouldnt match:\n"
"255.256.255.255\n"
"172.999.2.3\n"
"this is a string1.2.3.4\n"
"this is another 1.2.3.4string\n"
"144.109.279.255\n"
"v1.2.3.4\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.