package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?<tag>\w+)\s?=\s?(?<code>.*$)`)
var str = `[abilities]
UnknownDescTech0 = This ability does not seem to have any purpose.
UnknownName= ??? Ability
UnknownDescFun0 = No description
OneHitDeathName = 1-Hit Hero Badge
OneHitDeathDesc0 = You die in one hit. Only for the brave!
AddElement = Test Text.
[spaceship]
SuckInOrbsName = Item Magnet Badge
SuckInOrbsFun0 = Item just out of reach? No longer a problem!
SuckInOrbsTech0 = Automatically attract nearby collectibles!"
[test]
hub_alert_generic0 = …[trophy]hub_alert_generic1 = [icon:trophy][trophy]今年度鳥映画アワード[/trophy]は内部の者によって不正に染まっていた。
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}