const regex = /(?<tag>\w+)\s?=\s?(?<code>.*$)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<tag>\\w+)\\s?=\\s?(?<code>.*$)', 'gm')
const str = `[abilities]
UnknownDescTech0 = This ability does not seem to have any purpose.
UnknownName= ??? Ability
UnknownDescFun0 = No description
OneHitDeathName = 1-Hit Hero Badge
OneHitDeathDesc0 = You die in one hit. Only for the brave!
AddElement = Test Text.
[spaceship]
SuckInOrbsName = Item Magnet Badge
SuckInOrbsFun0 = Item just out of reach? No longer a problem!
SuckInOrbsTech0 = Automatically attract nearby collectibles!"
[test]
hub_alert_generic0 = …[trophy]hub_alert_generic1 = [icon:trophy][trophy]今年度鳥映画アワード[/trophy]は内部の者によって不正に染まっていた。
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}