package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^([A-Z]+)(\d+)((?:\.)\d+)?`)
var str = `M1000.7
MW300
PIW346`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}