$re = '/^([A-Z]+)(\d+)((?:\.)\d+)?/m';
$str = 'M1000.7
MW300
PIW346';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);