const regex = /(b[^]*)/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(b[^]*)', '')
const str = `map apple dog apple banana apple banana apple`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}