#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)^(?:u|(?:a\.|i[1,3-5]\.)?c|h1\-c0[1-7]|h3\-c0[1-4]|h5\-c0[1-5])\.eset\.com|(?:avcloud|dnsj)\.e5\.sk$"
Local $sString = "h1-c01.eset.com" & @CRLF & _
"h1-c02.eset.com" & @CRLF & _
"h1-c03.eset.com" & @CRLF & _
"h1-c04.eset.com" & @CRLF & _
"h1-c05.eset.com" & @CRLF & _
"h1-c06.eset.com" & @CRLF & _
"h1-c07.eset.com" & @CRLF & _
"h3-c01.eset.com" & @CRLF & _
"h3-c02.eset.com" & @CRLF & _
"h3-c03.eset.com" & @CRLF & _
"h3-c04.eset.com" & @CRLF & _
"h5-c01.eset.com" & @CRLF & _
"h5-c02.eset.com" & @CRLF & _
"h5-c03.eset.com" & @CRLF & _
"h5-c04.eset.com" & @CRLF & _
"h5-c05.eset.com" & @CRLF & _
"avcloud.e5.sk" & @CRLF & _
"dnsj.e5.sk" & @CRLF & _
"u.eset.com" & @CRLF & _
"c.eset.com" & @CRLF & _
"a.c.eset.com" & @CRLF & _
"i1.c.eset.com" & @CRLF & _
"i3.c.eset.com" & @CRLF & _
"i4.c.eset.com" & @CRLF & _
"i5.c.eset.com"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")