import re
regex = re.compile(r"^(?:u|(?:a\.|i[1,3-5]\.)?c|h1\-c0[1-7]|h3\-c0[1-4]|h5\-c0[1-5])\.eset\.com|(?:avcloud|dnsj)\.e5\.sk$", flags=re.MULTILINE | re.IGNORECASE)
test_str = ("h1-c01.eset.com\n"
"h1-c02.eset.com\n"
"h1-c03.eset.com\n"
"h1-c04.eset.com\n"
"h1-c05.eset.com\n"
"h1-c06.eset.com\n"
"h1-c07.eset.com\n"
"h3-c01.eset.com\n"
"h3-c02.eset.com\n"
"h3-c03.eset.com\n"
"h3-c04.eset.com\n"
"h5-c01.eset.com\n"
"h5-c02.eset.com\n"
"h5-c03.eset.com\n"
"h5-c04.eset.com\n"
"h5-c05.eset.com\n"
"avcloud.e5.sk\n"
"dnsj.e5.sk\n"
"u.eset.com\n"
"c.eset.com\n"
"a.c.eset.com\n"
"i1.c.eset.com\n"
"i3.c.eset.com\n"
"i4.c.eset.com\n"
"i5.c.eset.com")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")