import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(BEGIN:VCARD([\\s\\S]*?)END:VCARD)";
final String string = "BEGIN:VCARD\n"
+ "VERSION:3.0\n"
+ "N:Doe;John;;;\n"
+ "FN:John Doe\n"
+ "ORG:Example.com Inc.;\n"
+ "TITLE:Imaginary test person\n"
+ "EMAIL;type=INTERNET;type=WORK;type=pref:johnDoe@example.org\n"
+ "TEL;type=WORK;type=pref:+1 617 555 1212\n"
+ "TEL;type=WORK:+1 (617) 555-1234\n"
+ "TEL;type=CELL:+1 781 555 1212\n"
+ "TEL;type=HOME:+1 202 555 1212\n"
+ "NOTE:John Doe has a long and varied history\\, being documented on more police files that anyone else. Reports of his death are alas numerous.\n"
+ "CATEGORIES:Work,Test group\n"
+ "X-ABUID:5AD380FD-B2DE-4261-BA99-DE1D1DB52FBE\\:ABPerson\n"
+ "END:VCARD\n"
+ "BEGIN:VCARD\n"
+ "VERSION:3.0\n"
+ "N:Doe;Jane;;;\n"
+ "FN:Jane Doe\n"
+ "ORG:Example.com Inc.;\n"
+ "TITLE:Another Imaginary test person\n"
+ "EMAIL;type=INTERNET;type=WORK;type=pref:johnDoe@example.org\n"
+ "TEL;type=WORK;type=pref:+1 617 555 1213\n"
+ "TEL;type=WORK:+1 (617) 555-1233\n"
+ "TEL;type=CELL:+1 781 555 1213\n"
+ "TEL;type=HOME:+1 202 555 1213\n"
+ "NOTE:Jane Doe has a long and varied history\\, being documented on more police files that anyone else. Reports of her death are alas numerous.\n"
+ "CATEGORIES:Work,Test group\n"
+ "X-ABUID:5AD380FD-B2DE-4261-BA99-DE1D1DB52FBE\\:ABPerson\n"
+ "END:VCARD";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}