# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(BEGIN:VCARD([\s\S]*?)END:VCARD)"
test_str = ("BEGIN:VCARD\n"
"VERSION:3.0\n"
"N:Doe;John;;;\n"
"FN:John Doe\n"
"ORG:Example.com Inc.;\n"
"TITLE:Imaginary test person\n"
"EMAIL;type=INTERNET;type=WORK;type=pref:johnDoe@example.org\n"
"TEL;type=WORK;type=pref:+1 617 555 1212\n"
"TEL;type=WORK:+1 (617) 555-1234\n"
"TEL;type=CELL:+1 781 555 1212\n"
"TEL;type=HOME:+1 202 555 1212\n"
"NOTE:John Doe has a long and varied history\\, being documented on more police files that anyone else. Reports of his death are alas numerous.\n"
"CATEGORIES:Work,Test group\n"
"X-ABUID:5AD380FD-B2DE-4261-BA99-DE1D1DB52FBE\\:ABPerson\n"
"END:VCARD\n"
"BEGIN:VCARD\n"
"VERSION:3.0\n"
"N:Doe;Jane;;;\n"
"FN:Jane Doe\n"
"ORG:Example.com Inc.;\n"
"TITLE:Another Imaginary test person\n"
"EMAIL;type=INTERNET;type=WORK;type=pref:johnDoe@example.org\n"
"TEL;type=WORK;type=pref:+1 617 555 1213\n"
"TEL;type=WORK:+1 (617) 555-1233\n"
"TEL;type=CELL:+1 781 555 1213\n"
"TEL;type=HOME:+1 202 555 1213\n"
"NOTE:Jane Doe has a long and varied history\\, being documented on more police files that anyone else. Reports of her death are alas numerous.\n"
"CATEGORIES:Work,Test group\n"
"X-ABUID:5AD380FD-B2DE-4261-BA99-DE1D1DB52FBE\\:ABPerson\n"
"END:VCARD")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.