#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?s)(?<="Year": 2020.*?)"Year": 2020"
Local $sString = "[" & @CRLF & _
" {" & @CRLF & _
" "MyField": "Hello World"," & @CRLF & _
" "Year": 2020" & @CRLF & _
" }," & @CRLF & _
" {" & @CRLF & _
" "MyField": "foo bar"," & @CRLF & _
" "Year": 2020" & @CRLF & _
" }," & @CRLF & _
" {" & @CRLF & _
" "MyField": "mystring1"," & @CRLF & _
" "Year": 2020" & @CRLF & _
" }" & @CRLF & _
"]"
Local $sSubst = ""Year": 2021"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)