const regex = /(?<="Year": 2020.*?)"Year": 2020/gs;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<="Year": 2020.*?)"Year": 2020', 'gs')
const str = `[
{
"MyField": "Hello World",
"Year": 2020
},
{
"MyField": "foo bar",
"Year": 2020
},
{
"MyField": "mystring1",
"Year": 2020
}
]`;
const subst = `"Year": 2021`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);