import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(personal-loan|yourmortgageapp|lending).wf.com|^wellsfargo.com|^apply.wellsfargo.com";
final String string = "wellsfargo.com\n"
+ "apply.wellsfargo.com\n"
+ "wapppply.wellsfargo.com\n"
+ "test.wellsfargo.com\n"
+ "lending.wf.com\n"
+ "lending-loans.wf.com\n"
+ "yourmortgageapp.wf.com\n"
+ "personal-loan.wf.com\n"
+ "personalloans.wf.com\n"
+ "wellsfargo.com/werasefefraewr/adsfgdsfgsdfrg/dersgesrg";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}