using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"TotalDuration \[(?:.+ )?(.*?)\] Categories";
string input = @"TotalDuration [1 day, 2:09:13.830470] Categories
TotalDuration [2:09:13.830470] Categories";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}