$re = '/TotalDuration \[(?:.+ )?(.*?)\] Categories/m';
$str = 'TotalDuration [1 day, 2:09:13.830470] Categories
TotalDuration [2:09:13.830470] Categories';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);