import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:\\+?\\d+(?:\\h+\\d+)*,\\h*)?[^\\s@]+@[^\\s@,]+,\\h*www\\.\\S+|\\+?\\d+(?:\\h+\\d+)*";
final String string = "+35 00000000, info@company.com, www.company.com\n"
+ "+35 00000000, +360000000, info@company.com, www.company.com\n"
+ "info@company.com, www.company.com\n"
+ "+35 00000000, info@company1.com, www.company1.com, +36 00000000, info@company2.com, www.company2.com";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}