import re
regex = re.compile(r"(?:\+?\d+(?:\h+\d+)*,\h*)?[^\s@]+@[^\s@,]+,\h*www\.\S+|\+?\d+(?:\h+\d+)*", flags=re.MULTILINE)
test_str = ("+35 00000000, info@company.com, www.company.com\n"
"+35 00000000, +360000000, info@company.com, www.company.com\n"
"info@company.com, www.company.com\n"
"+35 00000000, info@company1.com, www.company1.com, +36 00000000, info@company2.com, www.company2.com")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")