$re = '/^(?!.*(?:no (?:further )?remediation req)).*remediat.*/mi';
$str = 'Remediation required
Record remediated
Record already remediated. No further remediation required
No remediation required
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);