re = /^(?!.*(?:no (?:further )?remediation req)).*remediat.*/mi
str = 'Remediation required
Record remediated
Record already remediated. No further remediation required
No remediation required
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end