$re = '/([^$\n]|^)\$\{[^}\n]*}?$/m';
$str = '${
${test
test${test
${$fdsf$
${test}
This would not match:
$${
$${test
${test}test
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);