re = /([^$\n]|^)\$\{[^}\n]*}?$/m
str = '${
${test
test${test
${$fdsf$
${test}
This would not match:
$${
$${test
${test}test
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end