$re = '/^(?:(.*?):)?\s*(.*)$/m';
$str = 'message accepted
update: message received
new status: user online
no new messages';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);