re = /^(?=.*[A-Z])(?=.*[!@#$%^&*()+_<>~-])(?=.*[0-9])(?=.*[a-z]).{8,15}$/m
str = '[]{}sS3_sss'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end