const regex = /:\s*(?<text>[^][:]+?)\s*(?<times>\d+)? \[id=(?<id>\d+)]/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp(':\\s*(?<text>[^][:]+?)\\s*(?<times>\\d+)? \\[id=(?<id>\\d+)]', 'gm')
const str = `example source text: hello world 1 [id=10000]`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}