$re = '/:\s*(?<text>[^][:]+?)\s*(?<times>\d+)? \[id=(?<id>\d+)]/m';
$str = 'example source text: hello world 1 [id=10000]';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);