package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^.*?\\[^0-9]*0*1\.pdf$`)
var str = `C:\Users\directory\Supplier\Invoice1.pdf
C:\Users\directory\Supplier\Invoice001.pdf
C:\Users\directory\Supplier\Invoice101.pdf
C:\Users\directory\Supplier\Invoice10.pdf
C:\Users\directory\Supplier\Invoice21.pdf`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}