$re = '/^.*?\\\\[^0-9]*0*1\.pdf$/m';
$str = 'C:\\Users\\directory\\Supplier\\Invoice1.pdf
C:\\Users\\directory\\Supplier\\Invoice001.pdf
C:\\Users\\directory\\Supplier\\Invoice101.pdf
C:\\Users\\directory\\Supplier\\Invoice10.pdf
C:\\Users\\directory\\Supplier\\Invoice21.pdf';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);