const regex = /-?[0-9]+\.[0-9]+/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('-?[0-9]+\\.[0-9]+', 'g')
const str = `cacacacacacaacacacacacaacacacacacacacacacacacacacacacacacacacacac"latitude":"900.252578";cacacacacacacacacacacacacacacaccacacacacacacacacacacacacacacacaccccacacacacaca"longitude":"0.997754"cacacacacacaacacacacacaacacacacacacacacacacacacacacacacacacacacac"latitude":"0.252578";cacacacacacacacacacacacacacacaccacacacacacacacacacacacacacacacaccccacacacacaca"longitude":"-0.997754"cacacacacacaacacacacacaacacacacacacacacacacacacacacacacacacacacac"latitude":"0.252578";cacacacacacacacacacacacacacacaccacacacacacacacacacacacacacacacaccccacacacacaca"longitude":"0.997754"cacacacacacaacacacacacaacacacacacacacacacacacacacacacacacacacacac"latitude":"0.252578";cacacacacacacacacacacacacacacaccacacacacacacacacacacacacacacacaccccacacacacaca"longitude":"0.997754"cacacacacacaacacacacacaacacacacacacacacacacacacacacacacacacacacac"latitude":"-0.252578";cacacacacacacacacacacacacacacaccacacacacacacacacacacacacacacacaccccacacacacaca"longitude":"0.997754"cacacacacacaacacacacacaacacacacacacacacacacacacacacacacacacacacac"latitude":"0.252578";cacacacacacacacacacacacacacacaccacacacacacacacacacacacacacacacaccccacacacacaca"longitude":"-0.997754"cacacacacacaacacacacacaacacacacacacacacacacacacacacacacacacacacac"latitude":"0.252578";cacacacacacacacacacacacacacacaccacacacacacacacacacacacacacacacaccccacacacacaca"longitude":"0.997754"cacacacacacaacacacacacaacacacacacacacacacacacacacacacacacacacacac"latitude":"0.252578";cacacacacacacacacacacacacacacaccacacacacacacacacacacacacacacacaccccacacacacaca"longitude":"0.997754"cacacacacacaacacacacacaacacacacacacacacacacacacacacacacacacacacac"latitude":"0.252578";cacacacacacacacacacacacacacacaccacacacacacacacacacacacacacacacaccccacacacacaca"longitude":"0.997754"cacacacacacaacacacacacaacacacacacacacacacacacacacacacacacacacac`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}