// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"-?[0-9]+\.[0-9]+").unwrap();
let string = "cacacacacacaacacacacacaacacacacacacacacacacacacacacacacacacacacac\"latitude\":\"900.252578\";cacacacacacacacacacacacacacacaccacacacacacacacacacacacacacacacaccccacacacacaca\"longitude\":\"0.997754\"cacacacacacaacacacacacaacacacacacacacacacacacacacacacacacacacacac\"latitude\":\"0.252578\";cacacacacacacacacacacacacacacaccacacacacacacacacacacacacacacacaccccacacacacaca\"longitude\":\"-0.997754\"cacacacacacaacacacacacaacacacacacacacacacacacacacacacacacacacacac\"latitude\":\"0.252578\";cacacacacacacacacacacacacacacaccacacacacacacacacacacacacacacacaccccacacacacaca\"longitude\":\"0.997754\"cacacacacacaacacacacacaacacacacacacacacacacacacacacacacacacacacac\"latitude\":\"0.252578\";cacacacacacacacacacacacacacacaccacacacacacacacacacacacacacacacaccccacacacacaca\"longitude\":\"0.997754\"cacacacacacaacacacacacaacacacacacacacacacacacacacacacacacacacacac\"latitude\":\"-0.252578\";cacacacacacacacacacacacacacacaccacacacacacacacacacacacacacacacaccccacacacacaca\"longitude\":\"0.997754\"cacacacacacaacacacacacaacacacacacacacacacacacacacacacacacacacacac\"latitude\":\"0.252578\";cacacacacacacacacacacacacacacaccacacacacacacacacacacacacacacacaccccacacacacaca\"longitude\":\"-0.997754\"cacacacacacaacacacacacaacacacacacacacacacacacacacacacacacacacacac\"latitude\":\"0.252578\";cacacacacacacacacacacacacacacaccacacacacacacacacacacacacacacacaccccacacacacaca\"longitude\":\"0.997754\"cacacacacacaacacacacacaacacacacacacacacacacacacacacacacacacacacac\"latitude\":\"0.252578\";cacacacacacacacacacacacacacacaccacacacacacacacacacacacacacacacaccccacacacacaca\"longitude\":\"0.997754\"cacacacacacaacacacacacaacacacacacacacacacacacacacacacacacacacacac\"latitude\":\"0.252578\";cacacacacacacacacacacacacacacaccacacacacacacacacacacacacacacacaccccacacacacaca\"longitude\":\"0.997754\"cacacacacacaacacacacacaacacacacacacacacacacacacacacacacacacacac";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}