using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?!.*?\.{2,})[a-z0-9_\.]{2,32}$";
string input = @"n0de
invalid..username
capsareNOTallowedtoo
veryverylongnamearealsonotallowed
.owo.";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}