re = /^(?!.*?\.{2,})[a-z0-9_\.]{2,32}$/m
str = 'n0de
invalid..username
capsareNOTallowedtoo
veryverylongnamearealsonotallowed
.owo.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end