$re = '/^([^.]+?\.)?text\.com$/m';
$str = 'text.com
test.text.com
foo.test.text.com
foo2.no.match.here.text.com';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);