using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\d: (.*?)";
string input = @"Vou pegar tudo depois do número 1: esse é o trecho que quero pegar, até o final da linha
Esse trecho está em outra linha e não quero";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}