re = /\d: (.*?)/m
str = 'Vou pegar tudo depois do número 1: esse é o trecho que quero pegar, até o final da linha
Esse trecho está em outra linha e não quero'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end