using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"lo*";
string input = @"below there is legos.
do not step on the legos below,
or you will feel loooooooooow.";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}