$re = '/lo*/m';
$str = 'below there is legos.
do not step on the legos below,
or you will feel loooooooooow.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);