package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\w+\.\w+`)
var str = `Например такого вида:
普遍接受测试.世界
.لــــیككاثو
домен.рф`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}