$re = '/\w+\.\w+/u';
$str = 'Например такого вида:
普遍接受测试.世界
.لــــیككاثو
домен.рф';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);