#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)ExceptionName: (?<message>[^\.]+)"
Local $sString = "{" & @CRLF & _
"" & @CRLF & _
"MESSAGE : Failed to send " & @CRLF & _
"stack_trace : com.abc.xyz.package.ExceptionName: Missing A." & @CRLF & _
"at random.package.w(DummyFile1:45)" & @CRLF & _
"at random.package.x(DummyFile2:64)" & @CRLF & _
"at random.package.y(DummyFile3:79)" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"}" & @CRLF & _
"{" & @CRLF & _
"" & @CRLF & _
"MESSAGE : Failed to send " & @CRLF & _
"stack_trace : com.abc.xyz.package.ExceptionName: Missing B." & @CRLF & _
"at random.package.w(DummyFile1:45)" & @CRLF & _
"at random.package.x(DummyFile2:64)" & @CRLF & _
"at random.package.y(DummyFile3:79)" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"}" & @CRLF & _
"{" & @CRLF & _
"" & @CRLF & _
"MESSAGE : Failed to send " & @CRLF & _
"stack_trace : com.abc.xyz.package.ExceptionName: Missing C." & @CRLF & _
"at random.package.w(DummyFile1:45)" & @CRLF & _
"at random.package.x(DummyFile2:64)" & @CRLF & _
"at random.package.y(DummyFile3:79)" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"}"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")