import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "ExceptionName: (?<message>[^\\.]+)";
final String string = "{\n\n"
+ "MESSAGE : Failed to send \n"
+ "stack_trace : com.abc.xyz.package.ExceptionName: Missing A.\n"
+ "at random.package.w(DummyFile1:45)\n"
+ "at random.package.x(DummyFile2:64)\n"
+ "at random.package.y(DummyFile3:79)\n\n\n\n"
+ "}\n"
+ "{\n\n"
+ "MESSAGE : Failed to send \n"
+ "stack_trace : com.abc.xyz.package.ExceptionName: Missing B.\n"
+ "at random.package.w(DummyFile1:45)\n"
+ "at random.package.x(DummyFile2:64)\n"
+ "at random.package.y(DummyFile3:79)\n\n\n\n"
+ "}\n"
+ "{\n\n"
+ "MESSAGE : Failed to send \n"
+ "stack_trace : com.abc.xyz.package.ExceptionName: Missing C.\n"
+ "at random.package.w(DummyFile1:45)\n"
+ "at random.package.x(DummyFile2:64)\n"
+ "at random.package.y(DummyFile3:79)\n\n\n\n"
+ "}";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}